Some AMD users have been posting on social media, including Reddit, about experiencing intermittent connectivity problems when using USB ports on their 500-series motherboards. In response, AMD has reached out through a Reddit post that it has been made aware of the connectivity issues, and is requesting more information from specific users with the issue to help them resolve it. Since this announcement, many users have been reaching out to AMD.

AMD's X570 motherboards have been readily available since July 2019, and its B550 models have been available since June 2020 and have both become well established over the course of the last year and a half. The fact that users are now having USB issues begs the question whether the issues have been present all along but are now rising above the noise, or there is something related to the longevity of these systems.

AMD 500 Series Motherboard and USB Connectivity Issues?

The most common reproduction of this issue appears to be during the use of Virtual Reality headsets such as the Oculus Rift and HTC Vive, with an intermittent connection issue being more prevalent to these users. As USB is the main method to power and communicate with VR headsets and peripherals, any dropout, even slightly to the high-powered VR applications, would instantly be highlighted. That isn't the only problem it can cause, as streaming devices and USB audio interfaces could also experience power dropouts, which could be quite noticeable, especially if doing a recording.

While AMD hasn't pinpointed the exact cause of the issue yet, it asks its users to reach out to them over on Reddit by u/AMDOfficial, which is an official support channel for AMD. Extensively combing through user comments on Reddit, it doesn't seem to be solely related just to one section of hardware. Some of the issues that users report seem to stem from the release of PCIe 4.0 graphics cards on 500 series motherboards. Reddit user u/duddy32 also states that they have been having these issues with a B450 motherboard and a Ryzen 7 3700X processor, which precede the 500-series chipset. 

AMD's B550 Chipset layout, including USB connectivity.

One possible workaround touted to reduce (but importantly not completely stop) the issues is users changing the motherboards' settings from PCIe 4.0 to PCIe 3.0. Users on Reddit have been reporting although it has reduced the frequency of dropouts, it hasn't eliminated them, which could point to an issue between the USB hub controller and other parts of the chipset. Some users are also reporting the issue to be primarily on USB 2.0 ports, and some have had success by switching devices to USB 3.1 ports. It is also recommended to update the firmware to the latest AGESA version on models, which could reduce issues. Although at this point, it's possible to presume that none of the workarounds could fix these problems users are experiencing with random and intermittent USB cutouts.

Although AMD hasn't notified the reddit audience if it has been able to pinpoint the issue internally, it is asking users experiencing these issues to detail their hardware configurations and other relevant system information to allow AMD to recreate the issues on its end. AMD is also openly encouraging users to directly raise online service requests with AMD customer support to help correlate data and compare notes with other support claims to narrow down the problem potentially.

The rear panel of an X70 motherboard with USB 3.1, USB 3.0, and USB 2.0 ports.

It should be noted that not all users have experienced these issues - we've tested several dozen AMD AM4 motherboards and have used them extensively over the last 15 months, with exactly zero issues related to this. This is why this issue might only be being highlighted now - either users haven't noticed the issue, as a very slight cutout from a mouse or keyboard may not be very apparent, or they might be lucky that this issue doesn't affect them. However, enough users are coming forward with these intermittent USB connectivity issues to make the issue widespread across multiple models and processor combinations. This means the issue isn't specifically down to a certain manufacturer and looks more like an issue with AMD's chipset or how it connects from the USB hub to the chipset. 

If AMD does manage to pinpoint the issue with its in-house team and collaboration of consistent data points provided by its users, it's possible a future AGESA firmware update could alleviate the issues. Of course, if it is directly related to a design and hardware problem, which could be a much tougher nut to crack for AMD.

AMD's official statement posted on 02/20/21 can be found on Reddit here

Related Reading

Comments Locked


View All Comments

  • edzieba - Tuesday, February 23, 2021 - link

    Despite often being called a 'bus' PCIe is not a bus: It's a series of discrete point-to-point links. If a device on the PCIe link from the CPU (to the GPU) is supposedly causing issues with a different device on a different PCIe link from the chipset (to the sound card) then there is some management problem with the chipset or CPU, or a physical signal issue. A driver update for the device hung off the CPU can at best mitigate the impacts of the underlying issue.
  • CiccioB - Tuesday, February 23, 2021 - link

    Sorry, but this is not right.
    A bus is NOT a communication channel where more than two devices can communicate.
    USB is a bus (hence its name) even if it strictly point to point. And SPI (much older) is too, even though you have to manually select which device is hearing the master keeping the other ones deaf. Memory communication paths are a bus, even if they connect a single chip to a single memory controller (strictly single point-to-point bus).

    Said that, there can be lots of reasons why what should be transmissions on two separated bus can interfere each other. One of them is controller resource sharing, and another is badly design signal paths (even internally the IC). Others can be devices that are at the limit of their sensibility (bandwidth capacity) and too many communication ongoing on the controller may lower the voltages making signal degrade the small amount needed for loosing their capacity to bring a meaningful information to the other end of the bus (yes, it is a bus even if it point-to-point).
    There can be issues with higher clocks (PCI3 and PCI4 interfering with slower clocks).

    What is sure is that this kind of problem should have been left in the past.
    But is seems they are not, and this may give an idea why in all AMD's quarterly reports there has always been that division (the chipset one) that has always had a minus in front of the revenue value: maybe the chipset department is not up to the rest of the company.
    And one may ask if with the quality of that department (which is not only HW but also SW related) the company can really become a reliable alternative to Intel domination.
  • Alexvrb - Saturday, March 6, 2021 - link

    Minor point of contention regarding the "chipset department": B550 isn't an AMD chipset. X570 is. If seemingly random system configs across both chipsets and multiple generations of Zen are having issues, its likely the board designs. Given the recent BIOS tweaks I've seen from Gigabyte regarding USB stability, I'd lean towards that theory.
  • artifex - Wednesday, February 24, 2021 - link

    I thought I was outside the scope because I'm on a B450 also, with a 2600, but I've had some issues with USB3, too. The USB-C 3.2 gen 1 10 GB/s port on my ASRock board won't recognize when my Plugable NVMe enclosure is even connected, so I have to swap cables (it came with both USB-C and -A cables)and use the USB-A cable instead, on a slower port. The C port works okay with other stuff, though. On the other hand, my laptop with Intel inside can see and use the drive fine over its TB3/USB-C port. And when I check it with CrystalDiskInfo it shows incremented unexpected power loss numbers on the NVME stick inside from the desktop connections. And I think I'm at the latest UEFI revision my desktop board will support while still supporting my 2600. So the enclosure sits unused for now.
  • Alexvrb - Saturday, March 6, 2021 - link

    I wonder if a powered hub would resolve that. Not saying you should, just wondering aloud. Side note, this is why more motherboards should use larger BIOS ROM chips... you can get a combo BIOS with the latest tweaks, even if the CPU microcode loaded is the same. It's a lot more common among 500 series boards, my board has a 32MB ROM.
  • ZolaIII - Monday, February 22, 2021 - link

    I personally experienced it on B550 board from Gigabyte and ryzen 3xxx (Win 10 PCIe 3.0).
    At first USB 2.0 controler got crushed totally that I had to go to device menager and scan for hardware changes to get it back and it actually happened couple times in couple months. With the updated bios stating "improved USB stability" it doesn't get crushed any more but it had some stalls. It happens when their's lot of activity and while pushing it (gaming). But this is only related to USB 2.0 controllers the 3.1 ones work correctly.
    Personally I believe it's related to side control protocol bus used (think it's i2c) which gets overflown.
  • ZolaIII - Thursday, February 25, 2021 - link

    Update; it's early to say for sure but it seems USB 2.0 problems ware solved with latest (still beta) bios stating "AMD AGESA ComboV2,
    Improve USB 2.0 compatibility". Update resetts everything including higher profiles for MB and GPU so needles to say it whose unpleasant.
  • Alexvrb - Saturday, March 6, 2021 - link

    Yeah I'm not updating until the non-beta is out, don't want to redo my settings twice.
  • jcward - Monday, February 22, 2021 - link

    I've had tons of USB connectivity problems on my B550M / 3600XT in linux. I was blaming hubs / static, but now I'm not so sure... Interesting, thanks for the article!
  • cyrusfox - Monday, February 22, 2021 - link

    Funny as I have USB switch (switch between work laptop and desktop ) that causes my Comet lake platform to Blue screen all the time. . Its the second USB switch I have tried. Static sometimes causes it as well. I guess I should get out my Bulky KVM switch as those seem better designed but all I want to do is switch between platforms with the push of a button. USB issues aren't only an AMD thing. THats likely the issue with Universal standards that we keep modifying.

Log in

Don't have an account? Sign up now